Cisco - ProCurve Interoperability 2017-08-18آ  Spanning-Tree 31- Introduction 32- MSTP 33- PVST and

  • View
    0

  • Download
    0

Embed Size (px)

Text of Cisco - ProCurve Interoperability 2017-08-18آ  Spanning-Tree 31- Introduction 32- MSTP 33- PVST...

  • Spanning-Tree 31- Introduction 32- MSTP 33- PVST and RSTP

    321- Cisco as Core, ProCurve as Edge 322- ProCurve as Core, Cisco as Edge

    Introduction

    Glossary

    STP is Spanning-Tree Protocol The IEEE standard implementation of STP is 802.1D. RSTP is Rapid Spanning-Tree Protocol defined by the 802.1w IEEE standard. MSTP is Multiple Spanning-Tree Protocol defined by the 802.1s IEEE standard. PVST is Per VLAN Spanning-tree proprietary implementation of STP on Cisco equipment PVST+ is the implementation of PVST on 802.1q links.

    Spanning-Tree on HP ProCurve Switches

    802.1D and 802.1w (RSTP) All HP ProCurve switches implement both of these STP standards. On HP ProCurve, Spanning-Tree has to be activated, the default mode is then Rapid STP.

    MSTP 802.1s It is supported on most manageable switches except 2500 and 4100 switches Please refer to switch documentation.

    Spanning-Tree on Cisco Switches

    PVST+ By default, Cisco switches run PVST+. PVST is the implementation of STP on ISL links (Cisco proprietary multi-VLAN encapsulation) while PVST+ runs on 802.1q links .

    In PVST+, there is one instance of STP per VLAN and BPDUs use a proprietary Multicast Mac Address. They are not “understood” by HP ProCurve switches (except by ProCurve 9300M and 9400M) and are then flooded as a regular multicast. So, regarding PVST+ BPDUs, HP ProCurve switches appear as a hub. However, Native VLAN (untagged VLAN of a tagged link equal to VLAN 1 be default) is an exception. In Native VLAN, the Cisco switches send standard STP BPDUs, which are “understood” by HP ProCurve switches. This is how both platform interact.

  • Cisco has also introduced Rapid PVST+, a PVST+ implementation that integrates Rapid STP principles.

    Prestandard MSTP MSTP should not be confused with the prestandard version of MSTP.

    MSTP (802.1s) You must run the latest versions of IOS to get support of MSTP (check on Cisco web site).

    Caution Support for the IEEE 802.1s standard has been introduced around September 2005 by Cisco in the IOS. One should refer to Cisco web site for IOS support of compliant MSTP (*). Caution should be taken on not confusing the prestandard MST and the compliant IEEE 802.1s MST. If configuration of both modes looks exactly the same, the prestandard does NOT interoperate with the MSTP on ProCurve as this one complies with IEEE 802.1s standard.

    (*) Versions of IOS implementing the Compliant IEEE 802.1s starts with: 12.2(18) for Catalyst 6500, 12.2(25)SG for Catalyst 4500 and 12.2(25)SEC on Catalyst 35xx, 37xx, and 2970.

    What Spanning-Tree mode should you choose between Cisco and ProCurve Switches?

    MSTP is obviously the ideal choice because it is standard based and supported by both vendors, it converges quickly and allows load-balancing of traffic on uplinks with appropriate configuration.

    If not all your devices support MSTP yet, a progressive migration to MSTP can be put in place as it interoperates with Standard, Rapid Spanning Tree modes and with PVST via the Native Vlan.

    Note that all STP modes interoperate via the standard spanning-tree mode also named the Common Spanning-Tree (CST). So whatever is your choice, you should always carefully define the root and secondary root of the CST. On Cisco look after priority of STP in the Native Vlan (vlan 1 by default), on ProCurve look after the “global” priority of STP.

  • MSTP Configuration

    Procurve-Edge-1

    The parameters for the MSTP domain has been defined as followed: Configuration Name = procurve-cisco (case sensitive) Configuration Number = 1 Instance 1 = vlans 1, 10, 20 Instance 2 = vlans 30, 40

    Configuration of Cisco-Core-1

    hostname Core-Cisco-1

    Following defines MST mode (802.1s)

    spanning-tree mode mst spanning-tree extend system-id

    All parameters of the MSTP configuration must match on all switches of the MSTP domain.

    spanning-tree mst configuration name procurve-cisco revision 1 instance 1 vlan 1, 10, 20 instance 2 vlan 30, 40

    For load balancing of traffic among links, Cisco-core-1 is defined as Root of instance 0 and 1 (priority 0) and secondary root of instance 2 (priority 4096)

    spanning-tree mst 0-1 priority 0 spanning-tree mst 2 priority 4096

    VLAN Creation

    Procurve-Edge-2

    Gi1/3

    Cisco-Core-1

    e 1 e 2

    Gi1/1 Gi1/1

    Gi1/3

    Gi1/2 Gi1/2

    Cisco-Core-2

    e 1 e 2

  • VLAN 1 exists by default

    vlan 10,20,30,40

    Uplinks are defined as 802.1q links. They are named “trunks” in Cisco terminology and “tagged links” in ProCurve terminology. The “nonegogiate” feature means that we do no use the Dynamic Trunk Protocol to negotiate the status of the uplink.

    interface range GigabitEthernet0/1 - 3 switchport trunk encapsulation dot1q switchport mode trunk switchport nonegotiate

    Access ports (Cisco Terminology) or Edge ports (ProCurve terminology) are defined as untagged members of a Vlan. The portfast mode defines them as Edge port in Spanning tree terminology.

    Interface range GigabitEthernet0/4 -10 switchport access vlan 10 switchport mode access spanning-tree portfast ! interface range GigabitEthernet0/11 - 24 switchport access vlan 20 switchport mode access spanning-tree portfast

    IP configuration. ip routing

    The Virtual IP used as Default Gateway for the various VLANs are set using HSRP (Hot Standby Router Protocol), the Cisco proprietary protocol. As Cisco-Core-1 is the Root of MST instance 1, we also set it as Master of the Virtual IP of Vlans 1, 10 & 20. And as it is secondary root for MST instance 2, we define it as the Backup of Virtual IP in Vlans 30 & 40.

    interface Vlan1 ip address 10.1.1.1 255.255.255.0 standby 1 ip 10.1.1.254 standby 1 timers 1 3 standby 1 priority 255 standby 1 preempt ! interface Vlan10 ip address 10.1.10.1 255.255.255.0 standby 10 ip 10.1.10.254 standby 10 timers 1 3 standby 10 priority 255 standby 10 preempt ! interface Vlan20 ip address 10.1.20.1 255.255.255.0 standby 20 ip 10.1.20.254 standby 20 timers 1 3 standby 20 priority 255 standby 20 preempt ! interface Vlan30 ip address 10.1.30.1 255.255.255.0 standby 30 ip 10.1.30.254 standby 30 timers 1 3 ! interface Vlan40

  • ip address 10.1.40.1 255.255.255.0 standby 40 ip 10.1.40.254 standby 40 timers 1 3 !

    end

    Core-cisco-2 configuration

    hostname Core-Cisco-2 !

    Global Configuration is similar to the configuration of Cisco-Core-1

    spanning-tree mode mst spanning-tree extend system-id

    spanning-tree mst configuration name procurve-cisco revision 1 instance 1 vlan 1, 10, 20 instance 2 vlan 30, 40

    For load balancing of traffic among uplinks, Cisco-core-2 is defined as Root of instance 2 (priority 0) and secondary root of instance 0 and 1 (priority 4096)

    spanning-tree mst 0-1 priority 4096 spanning-tree mst 2 priority 0 ! vlan 10,20,30,40 !

    For load balancing of traffic among uplinks, Cisco-core-2 is defined as Root of instance 2 and secondary root of instances 0 and 1.

    interface range GigabitEthernet0/1 - 3 switchport trunk encapsulation dot1q switchport mode trunk switchport nonegotiate ! ! ip routing

    Because Cisco-Core-2 is set as the secondary Root of MST instance 1, we define it as HSRP backup of the Virtual IP of VLANs 1, 10 & 20. And because it is root of MST instance 2, we set it as the Master of Virtual IP in VLANs 30 & 40.

    interface Vlan1 ip address 10.1.1.2 255.255.255.0 standby 1 ip 10.1.1.254 standby 1 timers 1 3 ! interface Vlan10 ip address 10.1.10.2 255.255.255.0 standby 10 ip 10.1.10.254 standby 10 timers 1 3 ! interface Vlan20 ip address 10.1.20.2 255.255.255.0 standby 20 ip 10.1.20.254 standby 20 timers 1 3 ! interface Vlan30 ip address 10.1.30.2 255.255.255.0 standby 30 ip 10.1.30.254 standby 30 timers 1 3 standby 30 priority 255

  • standby 30 preempt ! interface Vlan40 ip address 10.1.40.2 255.255.255.0 standby 40 ip 10.1.40.254 standby 40 timers 1 3 standby 40 priority 255 standby 40 preempt

    end

    ProCurve-Edge-1 Configuration

    ProCurve-Edge-1 is a 3500yl.

    hostname "ProCurve-Edge-1"

    VLAN configuration

    Uplinks ports are 1 and 2 vlan 1 name "DEFAULT_VLAN" untagged 1-24 ip address 10.1.1.3 255.255.255.0 exit vlan 10 name "VLAN10" untagged 11-15 tagged 1-2 no ip address exit vlan 20 name "VLAN20" untagged 16-20 tagged 1-2 no ip address exit vlan 30 name "VLAN30" untagged 21-25 tagged 1-2 no ip address exit vlan 40 name "VLAN40" untagged 25-30 tagged 1-2 no ip address exit

    Let’s enable Spanning-tree. It default on MSTP on the latest ProCurve switches: 3500yl, 5400zl and 4200vl

    spanning-tree

    Default port configuration in MSTP is non Edge and Point-to-Point. We define Edge ports as “Edge”.

    spanning-tree 11-30 edge-port

    MSTP Configuration: Name, Revision and instances match the one of other switches in MSTP domain

    spanning-tree config-name "procurve-cisco" spanning-tree config-revision 1

  • spanning-tree instance 1 vlan 1 10 20 spanning-tree instance 2 vlan 30 40

    ProCurve-Edge-2 Configuration

    Configuration is similar to the configuration of ProCurve-Edge-1. In our example ProCurve-Edge-2 is a 3400. Spanning-tree mode defaults to RSTP. And we have to turn it on MSTP mode that requires a reboot.

    hos