24
Cisco Networking Academy Threaded Case Study December 2007

Cisco Networking Class Final Assignment

Embed Size (px)

Citation preview

Page 1: Cisco Networking Class Final Assignment

Cisco Networking

Academy

Threaded Case Study

December 2007

Page 2: Cisco Networking Class Final Assignment

Team

IT Director: Jason Mora

Area 1 District Administrator: Nathan Searle

Area 2 District Administrator: Morgan Tucker

Area 3 District Administrator: Dustin Curry

Page 3: Cisco Networking Class Final Assignment

Objective

Plan and design a structured network for two elementary

schools, two middle schools, a high school, and the MDF in

the superintendent of schools building where the primary

WAN link to the ISP is located.

Page 4: Cisco Networking Class Final Assignment

Network Features

The network uses a partial mesh design for redundancy, OPSF routingprotocol with each administrative area on a separate OSPF area, andPPP with authentication (chap) for the WAN link.

Private addressing is used internally on the OSPF autonomous systemwith NAT translations to real world IPs through the border router to theISP.

VLANs are set up on each school’s transport layer, separatingadministrator, faculty, support staff, and student networks.

Standard ACLs are used to prevent students from accessing the otherVLANs as well as the student VLANs on other networks and extendedACLs to prevent anyone outside the network from using telnet to accessnetwork resources.

Our design was tested using serial WAN links which will be replaced withfaster, higher bandwidth fiber in actual implementation.

Three layer design (MDF Core Layer, Distribution Layer, and AccessLayer) with floating static routes in case routing protocol fails.

Page 5: Cisco Networking Class Final Assignment

Requirements and Specifications

ISP WAN Link Network: 195.16.16.64 /30

ISP WAN Default Gateway: 195.16.16.65 /30

ISP Provided IP Range: 203.134.13.0 /28

Each elementary and middle school is budgeted for 6 administrators,

40 faculty, 60 support staff, and 400 students with a projected

increase of 30%

The high school is budgeted for 8 administrators, 60 faculty, 70

support staff, and 800 students with a projected increase of 50%

Page 6: Cisco Networking Class Final Assignment

Private Addressing

Elementary School 1: 172.16.0.0 /16

Elementary School 2: 172.17.0.0 /16

Middle School 1: 172.18.0.0 /16

Middle School 2: 172.19.0.0 /16

High School: 172.20.0.0 /16

Superintendent (MDF): 172.21.0.0 /16

WAN Links: 172.22.0.0 /24

Page 7: Cisco Networking Class Final Assignment

Network Topology

Page 8: Cisco Networking Class Final Assignment

Area 0, Superintendent

Superintendent (MDF)SuperInt (Router)

S0/0/0: 195.16.16.65 /30 (DTE)

S0/0/1: 172.22.0.5 /30 (DCE)

S0/1/0: 172.22.0.9 /30 (DCE)

S0/1/1: 172.22.0.1 /30 (DCE)

FA0/1: (Trunk .1q)

FA0/0.1: 172.21.0.1 /27 (VLAN 1)

FA0/0.2: 172.21.0.33 /27 (VLAN 2)

SuperIntS (Switch)

FA0/9: Trunk

FA0/1 – FA0/14: VLAN 1

FA0/15 – FA0/24: VLAN 2

VLAN Information

VLAN 1, Administrators (25 Hosts)

VLAN 2, Faculty (30 Hosts)

Page 9: Cisco Networking Class Final Assignment

enable

config t

hostname SuperInt

enable password cisco

enable secret class

line con 0

password cisco

login

exit

line vty 0 4

password cisco

login

exit

int s0/0/0

ip address 195.16.16.65 255.255.255.252

no shutdown

ip nat outside

encap ppp

ppp authentication chap

username ISP password cisco

exit

int s0/0/1

ip address 172.22.0.5 255.255.255.252

ip nat inside

clock rate 125000

no shutdown

exit

int Serial0/1/0

no shutdown

ip address 172.22.0.9 255.255.255.252

ip nat inside

clock rate 125000

exit

int Serial0/1/1

no shutdown

ip address 172.22.0.1 255.255.255.252

ip nat inside

clock rate 125000

exit

Superintendent Router Configuration

int fa0/1

no shutdown

exit

int fa0/1.1

encap dot1q 1

ip address 172.21.0.1 255.255.255.224

ip nat inside

exit

int fa0/1.2

encap dot1q 2

ip address 172.21.0.33 255.255.255.224

ip nat inside

exit

banner motd z

ADMINISTRATIVE ACCESS ONLYz

router ospf 1

network 172.21.0.0 0.0.0.0 area 0

network 172.21.0.0 0.0.0.31 area 0

network 172.21.0.0 0.0.255.255 area 0

network 172.22.0.0 0.0.0.0 area 0

network 172.22.0.0 0.0.0.3 area 3

network 172.22.0.4 0.0.0.3 area 2

network 172.22.0.8 0.0.0.3 area 1

network 195.16.16.64 0.0.0.3 area 0

exit

int loopback 0

ip address 195.16.16.16 255.255.255.255

no shutdown

exit

ip route 0.0.0.0 0.0.0.0 195.16.16.66

ip route 172.16.0.0 255.255.0.0 s0/1/0 120

ip route 172.17.0.0 255.255.0.0 s0/1/0 120

ip route 172.18.0.0 255.255.0.0 s0/1/1 120

ip route 172.19.0.0 255.255.0.0 s0/1/1 120

ip route 172.20.0.0 255.255.0.0 s0/0/1 120

access-list 1 permit 172.0.0.0 0.255.255.255

ip nat pool CAS 203.134.13.1 203.134.13.14 netmask 255.255.255.240

ip nat inside source list 1 pool CAS

access-list 101 deny tcp any any eq telnet

access-list 101 permit ip any any

access-list 2 deny 172.16.0.1 0.0.0.255

access-list 2 deny 172.17.0.1 0.0.0.255

access-list 2 deny 172.18.0.1 0.0.0.255

access-list 2 deny 172.19.0.1 0.0.0.255

access-list 2 deny 172.20.0.1 0.0.1.255

access-list 2 permit any

int fa0/0.1

ip access-group 2 out

exit

int fa0/0.2

ip access-group 2 out

exit

int s0/0/0

ip access-group 101 in

Page 10: Cisco Networking Class Final Assignment

enable

config t

hostname SuperIntS

enable password cisco

enable secret class

line con 0

password cisco

login

exit

line vty 0 15

password cisco

login

exit

ip default-gateway 172.21.0.1

int vlan1

ip address 172.21.0.2 255.255.0.0

no shutdown

end

vlan database

vlan 2 name Faculty

exit

config t

int fa0/1

switchport mode access

exit

int fa0/2

switchport mode access

exit

int fa0/3

switchport mode access

exit

int fa0/4

switchport mode access

exit

Superintendent Switch Configuration

int fa0/5

switchport mode access

exit

int fa0/6

switchport mode access

exit

int fa0/7

switchport mode access

exit

int fa0/8

switchport mode access

exit

int fa0/9

switchport mode trunk

exit

int fa0/10

switchport mode access

exit

int fa0/11

switchport mode access

exit

int fa0/12

switchport mode access

exit

int fa0/13

switchport mode access

exit

int fa0/14

switchport mode access

exit

int fa0/15

switchport mode access

switchport access vlan 2

exit

int fa0/16

switchport mode access

switchport access vlan 2

exit

int fa0/17

switchport mode access

switchport access vlan 2

exit

int fa0/18

switchport mode access

switchport access vlan 2

exit

int fa0/19

switchport mode access

switchport access vlan 2

exit

int fa0/20

switchport mode access

switchport access vlan 2

exit

int fa0/21

switchport mode access

switchport access vlan 2

exit

int fa0/22

switchport mode access

switchport access vlan 2

exit

int fa0/23

switchport mode access

switchport access vlan 2

exit

int fa0/24

switchport mode access

switchport access vlan 2

exit

Page 11: Cisco Networking Class Final Assignment

Area 1, Elementary SchoolsElementary School 1ElemOneRtr

S0/0: 172.22.0.13 /30 (DCE)

S0/1: 172.22.0.17 /30 (DCE)

FA0/0: (Trunk .1q)

FA0/0.1: 172.16.1.193 /28 (VLAN 1)

FA0/0.2: 172.16.1.129 /26 (VLAN 2)

FA0/0.3: 172.16.1.1 /25 (VLAN 3)

FA0/0.4: 172.16.0.1 /24 (VLAN 4)

ElemOneVLANSwitch

FA0/1: Trunk

FA0/2 – FA0/6: VLAN 1

FA0/7 – FA0/12: VLAN 2

FA0/13 – FA0/18: VLAN 3

FA0/19 – FA0/24: VLAN 4

Elementary School 2ElemTwoRtr

ElemOneVLANSwitch

FA0/1: Trunk

FA0/2 – FA0/6: VLAN 1

FA0/7 – FA0/12: VLAN 2

FA0/13 – FA0/18: VLAN 3

FA0/19 – FA0/24: VLAN 4

S0/0: 172.22.0.14 /30 (DTE)

S0/1: 172.22.0.10 /30 (DTE)

FA0/0: (Trunk .1q)

FA0/0.1: 172.17.1.193 /28 (VLAN 1)

FA0/0.2: 172.17.1.129 /26 (VLAN 2)

FA0/0.3: 172.17.1.1 /25 (VLAN 3)

FA0/0.4 172.17.0.1 /24 (VLAN 4)

VLAN InformationVLAN 1, Administrators (20 Hosts)

VLAN 2, Faculty (60 Hosts)

VLAN 3, Support Staff (80 Hosts)

VLAN 4, Computer Labs (200 Hosts)

Page 12: Cisco Networking Class Final Assignment

enable

config t

hostname ElemOneRouter

enable password cisco

enable secret class

line con 0

password cisco

login

exit

line vty 0 4

password cisco

login

exit

int s0/0

ip address 172.22.0.13 255.255.255.252

clock rate 56000

no shutdown

exit

int s0/1

ip address 172.22.0.17 255.255.255.252

clock rate 56000

no shutdown

exit

int fa0/0

no shutdown

exit

int fa0/0.1

encap dot1q 1

ip address 172.16.1.193 255.255.255.240

exit

int fa0/0.2

encap dot1q 2

ip address 172.16.1.129 255.255.255.192

exit

Elementary School 1 Router Configuration

int fa0/0.3

encap dot1q 3

ip address 172.16.1.1 255.255.255.128

exit

Int fa0/0.4

encap dot1q 4

ip address 172.16.0.1 255.255.255.0

exit

router ospf 1

network 172.16.0.0 0.0.255.255 area 1

network 172.22.0.12 0.0.0.3 area 1

network 172.22.0.16 0.0.0.3 area 1

exit

int loopback 0

ip address 192.168.1.10 255.255.255.255

no shutdown

exit

ip route 172.17.0.0 255.255.0.0 s0/0 120

ip route 172.18.0.0 255.255.0.0 s0/1 120

ip route 172.19.0.0 255.255.0.0 s0/0 120

ip route 172.20.0.0 255.255.0.0 s0/1 120

ip route 172.21.0.0 255.255.0.0 s0/0 120

access-list 1 deny 172.16.0.1 0.0.0.255

access-list 1 deny 172.17.0.1 0.0.0.255

access-list 1 deny 172.18.0.1 0.0.0.255

access-list 1 deny 172.19.0.1 0.0.0.255

access-list 1 deny 172.20.0.1 0.0.1.255

access-list 1 permit any

int fa0/0.1

ip access-group 1 out

exit

int fa0/0.2

ip access-group 1 out

exit

int fa0/0.3

ip access-group 1 out

exit

int fa0/0.4

ip access-group 1 out

exit

Page 13: Cisco Networking Class Final Assignment

enable

config t

hostname ElemOneVLANSwitch

enable password cisco

enable secret class

line con 0

password cisco

login

exit

line vty 0 15

password cisco

login

exit

ip default-gateway 172.16.1.193

int vlan1

ip address 172.16.1.194 255.255.255.0

no shutdown

end

vlan database

vlan 2 name Faculty

vlan 3 name Support_Staff

vlan 4 name Comp_Labs

exit

config t

int fa0/1

switchport mode trunk

exit

int fa0/2

switchport mode access

exit

int fa0/3

switchport mode access

exit

int fa0/4

switchport mode access

exit

int fa0/5

switchport mode access

exit

int fa0/6

switchport mode access

exit

Elementary School 1 Switch Configuration

int fa0/7

switchport mode access

switchport access vlan 2

exit

int fa0/8

switchport mode access

switchport access vlan 2

exit

int fa0/9

switchport mode access

switchport access vlan 2

exit

int fa0/10

switchport mode access

switchport access vlan 2

exit

int fa0/11

switchport mode access

switchport access vlan 2

exit

int fa0/12

switchport mode access

switchport access vlan 2

exit

int fa0/13

switchport mode access

switchport access vlan 3

exit

int fa0/14

switchport mode access

switchport access vlan 3

exit

int fa0/15

switchport mode access

switchport access vlan 3

exit

int fa0/16

switchport mode access

switchport access vlan 3

exit

int fa0/17

switchport mode access

switchport access vlan 3

exit

int fa0/18

switchport mode access

switchport access vlan 3

exit

int fa0/19

switchport mode access

switchport access vlan 4

exit

int fa0/20

switchport mode access

switchport access vlan 4

exit

int fa0/21

switchport mode access

switchport access vlan 4

exit

int fa0/22

switchport mode access

switchport access vlan 4

exit

int fa0/23

switchport mode access

switchport access vlan 4

exit

int fa0/24

switchport mode access

switchport access vlan 4

exit

Page 14: Cisco Networking Class Final Assignment

enable

config t

hostname ElemTwoRouter

enable password cisco

enable secret class

line con 0

password cisco

login

exit

line vty 0 4

password cisco

login

exit

int s0/0

ip address 172.22.0.10 255.255.255.252

no shutdown

exit

int s0/1

ip address 172.22.0.14 255.255.255.252

no shutdown

exit

int fa0/0

no shutdown

exit

int fa0/0.1

encap dot1q 1

ip address 172.17.1.193 255.255.255.240

exit

int fa0/0.2

encap dot1q 2

ip address 172.17.1.129 255.255.255.192

exit

Elementary School 2 Router Configurationint fa0/0.3

encap dot1q 3

ip address 172.17.1.1 255.255.255.128

exit

Int fa0/0.4

encap dot1q 4

ip address 172.17.0.1 255.255.255.0

exit

router ospf 1

network 172.17.0.0 0.0.255.255 area 1

network 172.22.0.8 0.0.0.3 area 1

network 172.22.0.12 0.0.0.3 area 1

exit

int loopback 0

ip address 192.168.1.11 255.255.255.255

no shutdown

exit

ip route 172.16.0.0 255.255.0.0 s0/0 120

ip route 172.18.0.0 255.255.0.0 s0/1 120

ip route 172.19.0.0 255.255.0.0 s0/0 120

ip route 172.20.0.0 255.255.0.0 s0/0 120

ip route 172.21.0.0 255.255.0.0 s0/1 120

access-list 1 deny 172.16.0.1 0.0.0.255

access-list 1 deny 172.17.0.1 0.0.0.255

access-list 1 deny 172.18.0.1 0.0.0.255

access-list 1 deny 172.19.0.1 0.0.0.255

access-list 1 deny 172.20.0.1 0.0.1.255

access-list 1 permit any

int fa0/0.1

ip access-group 1 out

exit

int fa0/0.2

ip access-group 1 out

exit

int fa0/0.3

ip access-group 1 out

exit

int fa0/0.4

ip access-group 1 out

exit

Page 15: Cisco Networking Class Final Assignment

enable

config t

hostname ElemTwoVLANSwitch

enable password cisco

enable secret class

line con 0

password cisco

login

exit

line vty 0 15

password cisco

login

exit

ip default-gateway 172.17.1.193

int vlan1

ip address 172.17.1.194 255.255.255.0

end

vlan database

vlan 2 name Faculty

vlan 3 name Support_Staff

vlan 4 name Comp_Labs

exit

config t

int fa0/1

switchport mode trunk

exit

int fa0/2

switchport mode access

exit

int fa0/3

switchport mode access

exit

int fa0/4

switchport mode access

exit

int fa0/5

switchport mode access

exit

int fa0/6

switchport mode access

exit

Elementary School 2 Switch Configuration

int fa0/7

switchport mode access

switchport access vlan 2

exit

int fa0/8

switchport mode access

switchport access vlan 2

exit

int fa0/9

switchport mode access

switchport access vlan 2

exit

int fa0/10

switchport mode access

switchport access vlan 2

exit

int fa0/11

switchport mode access

switchport access vlan 2

exit

int fa0/12

switchport mode access

switchport access vlan 2

exit

int fa0/13

switchport mode access

switchport access vlan 3

exit

int fa0/14

switchport mode access

switchport access vlan 3

exit

int fa0/15

switchport mode access

switchport access vlan 3

exit

int fa0/16

switchport mode access

switchport access vlan 3

exit

int fa0/17

switchport mode access

switchport access vlan 3

exit

int fa0/18

switchport mode access

switchport access vlan 3

exit

int fa0/19

switchport mode access

switchport access vlan 4

exit

int fa0/20

switchport mode access

switchport access vlan 4

exit

int fa0/21

switchport mode access

switchport access vlan 4

exit

int fa0/22

switchport mode access

switchport access vlan 4

exit

int fa0/23

switchport mode access

switchport access vlan 4

exit

int fa0/24

switchport mode access

switchport access vlan 4

exit

Page 16: Cisco Networking Class Final Assignment

Area 2, High SchoolHigh SchoolHS_Rtr

S0/0: 172.22.0.18 /30 (DTE)

S0/1: 172.22.0.6 /30 (DTE)

S0/3: 172.22.0.22 /30 (DTE)

FA0/0.1: 172.20.3.1 /27 (VLAN 1)

FA0/0.2: 172.20.2.129 /25 (VLAN 2)

FA0/0.3: 172.20.2.1 /25 (VLAN 3)

FA0/0.4: 172.20.0.1 /23 (VLAN 4)

HS_Switch

FA0/1: Trunk

FA0/2 – FA0/6: VLAN 1

FA0/7 – FA0/12: VLAN 2

FA0/13 – FA0/18: VLAN 3

FA0/19 – FA0/24: VLAN 4

VLAN Information

VLAN 1, Administrators (20 Hosts)

VLAN 2, Faculty (95 Hosts)

VLAN 3, Support Staff (110 Hosts)

VLAN 4, Computer Labs (500 Hosts)

Page 17: Cisco Networking Class Final Assignment

enable

config t

hostname HS_Rtr

enable password cisco

enable secret class

line con 0

password cisco

login

exit

line vty 0 4

password cisco

login

exit

int s0/0

ip address 172.22.0.18 255.255.255.252

no shutdown

exit

int s0/1

ip address 172.22.0.6 255.255.255.252

no shutdown

exit

int s0/3

ip address 172.22.0.22 255.255.255.252

no shutdown

exit

int fa0/0

no shutdown

exit

int fa0/0.1

encap dot1q 1

ip address 172.20.3.1 255.255.255.224

exit

int fa0/0.2

encap dot1q 2

ip address 172.20.2.129 255.255.255.128

exit

High School Router Configuration

int fa0/0.3

encap dot1q 3

ip address 172.20.2.1 255.255.255.128

exit

Int fa0/0.4

encap dot1q 4

ip address 172.20.0.1 255.255.254.0

exit

router ospf 1

network 172.20.0.0 0.0.1.255 area 2

network 172.22.0.4 0.0.0.3 area 2

network 172.22.0.16 0.0.0.3 area 2

network 172.22.0.20 0.0.0.3 area 2

exit

int loopback 0

ip address 192.168.1.20 255.255.255.255

no shutdown

exit

ip route 172.16.0.0 255.255.0.0 s0/0 120

ip route 172.17.0.0 255.255.0.0 s0/0 120

ip route 172.18.0.0 255.255.0.0 s0/3 120

ip route 172.19.0.0 255.255.0.0 s0/3 120

ip route 172.21.0.0 255.255.0.0 s0/1 120

access-list 1 deny 172.16.0.1 0.0.0.255

access-list 1 deny 172.17.0.1 0.0.0.255

access-list 1 deny 172.18.0.1 0.0.0.255

access-list 1 deny 172.19.0.1 0.0.0.255

access-list 1 deny 172.20.0.1 0.0.1.255

access-list 1 permit any

int fa0/0.1

ip access-group 1 out

exit

int fa0/0.2

ip access-group 1 out

exit

int fa0/0.3

ip access-group 1 out

exit

int fa0/0.4

ip access-group 1 out

exit

Page 18: Cisco Networking Class Final Assignment

enable

config t

hostname HS_Switch

enable password cisco

enable secret class

line con 0

password cisco

login

exit

line vty 0 15

password cisco

login

exit

ip default-gateway 172.20.3.1

int vlan1

ip address 172.20.3.2 255.255.255.224

no shutdown

end

vlan database

vlan 2 name Faculty

vlan 3 name Support_Staff

vlan 4 name Comp_Labs

exit

config t

int fa0/1

switchport mode trunk

exit

int fa0/2

switchport mode access

exit

int fa0/3

switchport mode access

exit

int fa0/4

switchport mode access

exit

int fa0/5

switchport mode access

exit

int fa0/6

switchport mode access

exit

High School Switch Configuration

int fa0/7

switchport mode access

switchport access vlan 2

exit

int fa0/8

switchport mode access

switchport access vlan 2

exit

int fa0/9

switchport mode access

switchport access vlan 2

exit

int fa0/10

switchport mode access

switchport access vlan 2

exit

int fa0/11

switchport mode access

switchport access vlan 2

exit

int fa0/12

switchport mode access

switchport access vlan 2

exit

int fa0/13

switchport mode access

switchport access vlan 3

exit

int fa0/14

switchport mode access

switchport access vlan 3

exit

int fa0/15

switchport mode access

switchport access vlan 3

exit

int fa0/16

switchport mode access

switchport access vlan 3

exit

int fa0/17

switchport mode access

switchport access vlan 3

exit

int fa0/18

switchport mode access

switchport access vlan 3

exit

int fa0/19

switchport mode access

switchport access vlan 4

exit

int fa0/20

switchport mode access

switchport access vlan 4

exit

int fa0/21

switchport mode access

switchport access vlan 4

exit

int fa0/22

switchport mode access

switchport access vlan 4

exit

int fa0/23

switchport mode access

switchport access vlan 4

exit

int fa0/24

switchport mode access

switchport access vlan 4

exit

Page 19: Cisco Networking Class Final Assignment

Area 3, Middle SchoolsMiddle_1_Rtr

S0/0: 172.22.0.26 /30 (DCE)

S0/1: 172.22.0.21 /30 (DCE)

FA0/0: (Trunk .1q)

FA0/0.1: 172.18.1.193 /28 (VLAN 1)

FA0/0.2: 172.18.1.129 /26 (VLAN 2)

FA0/0.3: 172.18.1.1 /25 (VLAN 3)

FA0/0.4: 172.18.0.1 /24 (VLAN 4)

Middle_1_Switch

FA0/1: Trunk

FA0/2 – FA0/6: VLAN 1

FA0/7 – FA0/12: VLAN 2

FA0/13 – FA0/18: VLAN 3

FA0/19 – FA0/24: VLAN 4

Middle School 2Middle_2_Rtr

Middle_2_Switch

FA0/1: Trunk

FA0/2 – FA0/6: VLAN 1

FA0/7 – FA0/12: VLAN 2

FA0/13 – FA0/18: VLAN 3

FA0/19 – FA0/24: VLAN 4

VLAN InformationVLAN 1, Administrators (20 Hosts)

VLAN 2, Faculty (60 Hosts)

VLAN 3, Support Staff (80 Hosts)

VLAN 4, Computer Labs (200 Hosts)

S0/0: 172.22.0.2 /30 (DTE)

S0/1: 172.22.0.25 /30 (DTE)

FA0/0: (Trunk .1q)

FA0/0.1: 172.19.1.193 /28 (VLAN 1)

FA0/0.2: 172.19.1.129 /26 (VLAN 2)

FA0/0.3: 172.19.1.1 /25 (VLAN 3)

FA0/0.4 172.19.0.1 /24 (VLAN 4)

Middle School 1

Page 20: Cisco Networking Class Final Assignment

enable

config t

hostname Middle_1_Rtr

enable password cisco

enable secret class

line con 0

password cisco

login

exit

line vty 0 4

password cisco

login

exit

int s0/0

description To Middle School 2

ip address 172.22.0.26 255.255.255.252

clock rate 64000

no shutdown

exit

int s0/1

description To High School

ip address 172.22.0.21 255.255.255.252

clock rate 64000

no shutdown

exit

int fa0/0

no shutdown

exit

int fa0/0.1

description VLAN 1 - Admin

encap dot1q 1

ip address 172.18.1.193 255.255.255.240

exit

int fa0/0.2

description VLAN 2 - Faculty

encap dot1q 2

ip address 172.18.1.129 255.255.255.192

exit

Middle School 1 Router Configuration

int fa0/0.3

description VLAN 3 – Support_Staff

encap dot1q 3

ip address 172.18.1.1 255.255.255.128

exit

Int fa0/0.4

description VLAN 4 – Comp_Labs

encap dot1q 4

ip address 172.18.0.1 255.255.255.0

exit

router ospf 1

network 172.18.0.0 0.0.255.255 area 3

network 172.22.0.20 0.0.0.3 area 3

network 172.22.0.24 0.0.0.3 area 3

exit

int loopback 0

ip address 192.168.1.30 255.255.255.255

no shutdown

exit

ip route 172.16.0.0 255.255.0.0 s0/1 120

ip route 172.17.0.0 255.255.0.0 s0/1 120

ip route 172.19.0.0 255.255.0.0 s0/0 120

ip route 172.20.0.0 255.255.0.0 s0/1 120

ip route 172.21.0.0 255.255.0.0 s0/0 120

access-list 1 deny 172.16.0.1 0.0.0.255

access-list 1 deny 172.17.0.1 0.0.0.255

access-list 1 deny 172.18.0.1 0.0.0.255

access-list 1 deny 172.19.0.1 0.0.0.255

access-list 1 deny 172.20.0.1 0.0.1.255

access-list 1 permit any

int fa0/0.1

ip access-group 1 out

exit

int fa0/0.2

ip access-group 1 out

exit

int fa0/0.3

ip access-group 1 out

exit

int fa0/0.4

ip access-group 1 out

exit

Page 21: Cisco Networking Class Final Assignment

enable

config t

hostname Middle_1_Swit

enable password cisco

enable secret class

line con 0

password cisco

login

exit

line vty 0 15

password cisco

login

exit

ip default-gateway 172.18.1.193

int vlan1

ip address 172.18.1.194 255.255.255.0

no shutdown

end

vlan database

vlan 2 name Faculty

vlan 3 name Support_Staff

vlan 4 name Comp_Labs

exit

config t

int fa0/1

switchport mode trunk

exit

int fa0/2

switchport mode access

exit

int fa0/3

switchport mode access

exit

int fa0/4

switchport mode access

exit

int fa0/5

switchport mode access

exit

int fa0/6

switchport mode access

exit

Middle School 1 Switch Configuration

int fa0/7

switchport mode access

switchport access vlan 2

exit

int fa0/8

switchport mode access

switchport access vlan 2

exit

int fa0/9

switchport mode access

switchport access vlan 2

exit

int fa0/10

switchport mode access

switchport access vlan 2

exit

int fa0/11

switchport mode access

switchport access vlan 2

exit

int fa0/12

switchport mode access

switchport access vlan 2

exit

int fa0/13

switchport mode access

switchport access vlan 3

exit

int fa0/14

switchport mode access

switchport access vlan 3

exit

int fa0/15

switchport mode access

switchport access vlan 3

exit

int fa0/16

switchport mode access

switchport access vlan 3

exit

int fa0/17

switchport mode access

switchport access vlan 3

exit

int fa0/18

switchport mode access

switchport access vlan 3

exit

int fa0/19

switchport mode access

switchport access vlan 4

exit

int fa0/20

switchport mode access

switchport access vlan 4

exit

int fa0/21

switchport mode access

switchport access vlan 4

exit

int fa0/22

switchport mode access

switchport access vlan 4

exit

int fa0/23

switchport mode access

switchport access vlan 4

exit

int fa0/24

switchport mode access

switchport access vlan 4

exit

Page 22: Cisco Networking Class Final Assignment

enable

config t

hostname Middle_2_Rtr

enable password cisco

enable secret class

line con 0

password cisco

login

exit

line vty 0 4

password cisco

login

exit

int s0/0

description To Super/Administration

ip address 172.22.0.2 255.255.255.252

no shutdown

exit

int s0/1

description To Middle School 1

ip address 172.22.0.25 255.255.255.252

no shutdown

exit

int fa0/0

no shutdown

exit

int fa0/0.1

description VLAN 1 - Admin

encap dot1q 1

ip address 172.19.1.193 255.255.255.240

exit

int fa0/0.2

description VLAN 2 - Faculty

encap dot1q 2

ip address 172.19.1.129 255.255.255.192

exit

Middle School 2 Router Configuration

int fa0/0.3

description VLAN 3 – Support_Staff

encap dot1q 3

ip address 172.19.1.1 255.255.255.128

exit

Int fa0/0.4

description VLAN 4 – Comp_Labs

encap dot1q 4

ip address 172.19.0.1 255.255.255.0

exit

router ospf 1

network 172.19.0.0 0.0.255.255 area 3

network 172.22.0.0 0.0.0.3 area 3

network 172.22.0.24 0.0.0.3 area 3

exit

int loopback 0

ip address 192.168.1.31 255.255.255.255

no shutdown

exit

ip route 172.16.0.0 255.255.0.0 s0/0 120

ip route 172.17.0.0 255.255.0.0 s0/0 120

ip route 172.18.0.0 255.255.0.0 s0/1 120

ip route 172.20.0.0 255.255.0.0 s0/1 120

ip route 172.21.0.0 255.255.0.0 s0/0 120

access-list 1 deny 172.16.0.1 0.0.0.255

access-list 1 deny 172.17.0.1 0.0.0.255

access-list 1 deny 172.18.0.1 0.0.0.255

access-list 1 deny 172.19.0.1 0.0.0.255

access-list 1 deny 172.20.0.1 0.0.1.255

access-list 1 permit any

int fa0/0.1

ip access-group 1 out

exit

int fa0/0.2

ip access-group 1 out

exit

int fa0/0.3

ip access-group 1 out

exit

int fa0/0.4

ip access-group 1 out

exit

Page 23: Cisco Networking Class Final Assignment

enable

config t

hostname Middle_2_Swit

enable password cisco

enable secret class

line con 0

password cisco

login

exit

line vty 0 15

password cisco

login

exit

ip default-gateway 172.19.1.193

int vlan1

ip address 172.19.1.194 255.255.255.0

no shutdown

end

vlan database

vlan 2 name Faculty

vlan 3 name Support_Staff

vlan 4 name Comp_Labs

exit

config t

int fa0/1

switchport mode trunk

exit

int fa0/2

switchport mode access

exit

int fa0/3

switchport mode access

exit

int fa0/4

switchport mode access

exit

int fa0/5

switchport mode access

exit

int fa0/6

switchport mode access

exit

Middle School 2 Switch Configuration

int fa0/7

switchport mode access

switchport access vlan 2

exit

int fa0/8

switchport mode access

switchport access vlan 2

exit

int fa0/9

switchport mode access

switchport access vlan 2

exit

int fa0/10

switchport mode access

switchport access vlan 2

exit

int fa0/11

switchport mode access

switchport access vlan 2

exit

int fa0/12

switchport mode access

switchport access vlan 2

exit

int fa0/13

switchport mode access

switchport access vlan 3

exit

int fa0/14

switchport mode access

switchport access vlan 3

exit

int fa0/15

switchport mode access

switchport access vlan 3

exit

int fa0/16

switchport mode access

switchport access vlan 3

exit

int fa0/17

switchport mode access

switchport access vlan 3

exit

int fa0/18

switchport mode access

switchport access vlan 3

exit

int fa0/19

switchport mode access

switchport access vlan 4

exit

int fa0/20

switchport mode access

switchport access vlan 4

exit

int fa0/21

switchport mode access

switchport access vlan 4

exit

int fa0/22

switchport mode access

switchport access vlan 4

exit

int fa0/23

switchport mode access

switchport access vlan 4

exit

int fa0/24

switchport mode access

switchport access vlan 4

exit

Page 24: Cisco Networking Class Final Assignment

Show Commands

Router Show Commands* show running-config:

A quick reference to view the current configuration

* show interface:

Shows the interface status and detailed information about the interface configuration

* show controllers:

Shows information about the type of cable, useful for determining if the serial cable is DCE or DTE and if the clock rate is set

* show cdp neighbor:

Shows directly connected Cisco devices

* show ip route:

Shows directly connected routes as well as routes learned through routing updates

* show access-lists:

Shows access lists and any matches

Switch Show Commands* show vlan:

Shows vlan information and assigned

interfaces

* show interface:

Shows information about the interface

configuration including assigned vlan and

switchport mode

* show running-config:

A quick reference to view the current configuration

* show trunk:

Shows trunk information

* show cdp neighbor:

Shows directly connected Cisco devices